Skip to main content

Pentaho+ documentation has moved!

The new product documentation portal is here. Check it out now at docs.hitachivantara.com

 

Hitachi Vantara Lumada and Pentaho Documentation

spec

pentaho.util. spec

AMD Module

require(["pentaho/util/spec"], function(spec) { /* code goes here */ });

Constructor

Name Description
new spec()

The util.spec contains utilities related with handling of specification objects.

Methods

Name Description
merge(specTarget, specSource) : object
Static

Merges a specification into another.

Constructor Details

new spec()

The util.spec contains utilities related with handling of specification objects.

Source: javascript/web/pentaho/util/spec.js, line 35

Methods Details

merge(specTarget, specSource) : object
Static

Merges a specification into another.

The target specification is modified, but the source specification isn't. The latter is actually deep-cloned, whenever full-subtrees are set at a target place, to prevent future merges from inadvertently changing the source's internal structures.

Source: javascript/web/pentaho/util/spec.js, line 62

Parameters:
Name Default Value Summary
specTarget : object

The target specification.

specSource : object

The source specification.

Returns:
Name Description
object

The target specification.