Skip to main content
Hitachi Vantara Lumada and Pentaho Documentation

spec

pentaho.visual.role. spec

The visual.role.spec namespace contains specification classes for describing visual role mappings.

Source: doc-js/pentaho/visual/role/spec/_namespace.jsdoc, line 17

Interfaces

Name Summary
IAbstractMapping

The spec.IMapping interface describes the object form of a visual role mapping instance.

IMapping

The spec.IMapping interface describes the object form of an internal visual role mapping instance.

IMappingField

The spec.IMappingField interface describes the object form of a visual role mapping field instance.

IMode

The spec.IMode interface describes the object form of a visual role operating mode instance.

Type Definitions

MappingField:  pentaho.visual.role.spec.IMappingField | string

A spec.MappingField represents the union of JS types that can be used to describe a visual role mapping field instance.

When an instance is described using object form, its specification is of the type spec.IMappingField.

Alternatively, a single string can be used to describe an instance, in which case it is taken to be the value of the name property.

Source: doc-js/pentaho/visual/role/spec/MappingField.jsdoc, line 17