spec
pentaho.type. spec
The type.spec
namespace contains specification interfaces and type definitions.
Source: doc-js/pentaho/type/spec/_namespace.jsdoc, line 17
Interfaces
Name | Summary |
---|---|
IComplex | The |
IComplexType | The |
IDate | The |
IFunction | The |
IInstance | The |
IList | The |
IListType | The |
IPropertyType | The |
ISimple | The |
ISimpleType | The |
IType | The |
ITypeDescriptor | The |
IValue | The |
IValueType | The |
Type Definitions
Complex: |
---|
A Like with all other value types, complex values can be described using the general object form. The object form conforms to Complex values support an additional form of value specification, the array form: an array of Take the following object form example:
Assuming that the two properties were defined in the order
However, note that array form can only be used if the |
Element: |
---|
A |
EnvironmentPropertyFilter: |
---|
A A An array filter matches an environment variable if any of the values in the array are the same exact value of the environment variable. Any other value is assumed to be a single value, and matches the environment variable if it is the same value. Source: doc-js/pentaho/type/spec/EnvironmentPropertyFilter.jsdoc, line 17 |
Instance: |
---|
A When an instance is described using object form, its specification is of type To describe an absent instance, use a |
List: |
---|
A Like with all other value types, list values can be described using the general object form. The object form conforms to List values support an additional form of value specification, the array form: an array of Take the following example of a number list in object form:
In array form, if we assume the type of the list is implied, the same list could be written simply as:
However, note that array form can only be used if the A list of complex values can be written in array form, and its complex elements be written in array form, as well. For example: |
PropertyDynamicAttribute(propType, keyArgs) : T | |||||||||||||
---|---|---|---|---|---|---|---|---|---|---|---|---|---|
The signature of a function of a dynamic attribute of a property. Examples of dynamic property attributes:
Source: doc-js/pentaho/type/spec/PropertyDynamicAttribute.jsdoc, line 17
|
PropertyType: |
---|
A When the value is a string, it's taken to represent a property whose Source: doc-js/pentaho/type/spec/PropertyType.jsdoc, line 17 |
Simple: |
---|
A Like with all other value types, simple values can be described using the general object form. The object form conforms to The following is an example of an object form specification:
If the formatted is not defined, it can be written more concisely as:
or, simply, as:
Note that, when the underlying JavaScript value is a plain object, it must always be described using the generic object form,
Note that a simple value cannot have a
A To know, exactly, which types of JavaScript values are accepted as specifications of a specific |
TypeReference: |
---|
The It can be one of the following: A type id stringA type's permanent When an identifier is permanent and does not contain any "/" character, it is considered a standard type and is taken relative to Pentaho's Note that relative AMD module identifiers, such as "./foo", are not supported. Example absolute, permanent identifier:
Example temporary identifier:
An instance constructor functionA reference to an instance constructor, like Example:
A type objectA type's singleton object, like Example:
A generic type specification objectA plain The special Example:
A list type shorthand specification arrayA shorter specification syntax to reference the List type, or derived list types of varied Example: Source: doc-js/pentaho/type/spec/TypeReference.jsdoc, line 17 |
Value: |
---|
A When a value instance is described using object form, its specification is of type To describe an absent instance, use a |