Skip to main content
Hitachi Vantara Lumada and Pentaho Documentation

spec

pentaho.instanceInfo. spec

The instanceInfo.spec namespace contains specification interfaces.

Source: doc-js/pentaho/instanceInfo/spec/_namespace.jsdoc, line 17

Interfaces

Name Summary
IDeclaration

The spec.IDeclaration interface declares an instance.

Type Definitions

Declarations:  Object.<<code>string, pentaho.instanceInfo.spec.IDeclaration>

The spec.Declarations interface is the configuration of the Instance Info API.

An object whose keys are instance identifiers and whose values are instance declarations.

The following is an Instance Info API configuration that declares two instances, my/john and my/peter:

require.config({
  config: {
    "pentaho/instanceInfo": {
      "my/john": {type: "my/Person"},
      "my/peter": {type: "my/Person"}
    }
  }
});

Source: doc-js/pentaho/instanceInfo/spec/Declarations.jsdoc, line 17