Skip to main content
Hitachi Vantara Lumada and Pentaho Documentation

spec

pentaho.typeInfo. spec

The typeInfo.spec namespace contains specification interfaces.

Source: doc-js/pentaho/typeInfo/spec/_namespace.jsdoc, line 17

Interfaces

Name Summary
IDeclaration

The spec.IDeclaration interface declares a type.

Type Definitions

Declarations:  Object.<<code>string, pentaho.typeInfo.spec.IDeclaration>

The spec.Declarations interface is the configuration of the Type Info API.

An object whose keys are type identifiers and whose values are type declarations.

The following is a Type Info API configuration that declares two types, my/Abstract and my/Basic, where the latter is a subtype of the former:

require.config({
  config: {
    "pentaho/typeInfo": {
      "my/Abstract": {alias: "A"},
      "my/Basic": {base: "A"}
    }
  }
});

Source: doc-js/pentaho/typeInfo/spec/Declarations.jsdoc, line 17