spec
pentaho.type. spec
The type.spec
namespace contains specification interfaces and type definitions.
Source: doc-js/pentaho/type/spec/_namespace.jsdoc, line 17
Interfaces
Name | Summary |
---|---|
IComplex | The |
IComplexProto | The |
IComplexTypeProto | The |
IContext | The |
IContextInstanceConfiguration | The |
IContextTypeConfiguration | The |
IDate | The |
IFunction | The |
IInstance | The |
IInstanceProto | The |
IInstanceResolve | The |
IList | The |
IListProto | The |
IListTypeProto | The |
IPropertyTypeProto | The |
ISimple | The |
ISimpleProto | The |
ISimpleTypeProto | The |
ITypeDescriptor | The |
ITypeProto | The |
ITypesResolve | The |
IValue | The |
IValueProto | The |
IValueTypeProto | The |
Type Definitions
ContextInstancesConfiguration: |
---|
The An object whose keys are instance identifiers and whose values are instance declarations. Source: doc-js/pentaho/type/spec/ContextInstancesConfiguration.jsdoc, line 17 See also: pentaho.type.InstancesContainer |
ContextTypesConfiguration: |
---|
The An object whose keys are type identifiers and whose values are type context configurations. Source: doc-js/pentaho/type/spec/ContextTypesConfiguration.jsdoc, line 17 |
PropertyDynamicAttribute(propType) : T | ||||||||||
---|---|---|---|---|---|---|---|---|---|---|
The signature of a function of a dynamic attribute of a property. Examples of dynamic property attributes:
Source: doc-js/pentaho/type/spec/PropertyDynamicAttribute.jsdoc, line 17
|
UComplex: | Nully |
---|
A Like with all other value types, complex values can be described using the general object form. The object form conforms to Complex values support an additional form of value specification, the array form: an array of Take the following object form example:
Assuming that the two properties were defined in the order
However, note that array form can only be used if the When a complex value is absent, it can be described with a |
UElement: |
---|
A To describe an absent instance, use a |
UEnvironmentPropFilter: |
---|
A A An array filter matches an environment variable if any of the values in the array are the same exact value of the environment variable. Any other value is assumed to be a single value, and matches the environment variable if it is the same value. Source: doc-js/pentaho/type/spec/UEnvironmentPropFilter.jsdoc, line 17 |
UInstance: |
---|
A When an instance is described using object form, its specification is of type To describe an absent instance, use a |
UInstanceModule() |
---|
The An instance module is either the instance factory function directly, or an array whose first elements are The instance factory function can declare as many arguments as the dependency references that precede it in the module array. The function is called with the values of the One last argument is supplied containing any configuration registered under the instance identifier (see The following is an example of the AMD module of a Type API named instance, an instance of an hypothetical Source: doc-js/pentaho/type/spec/UInstanceModule.jsdoc, line 17 See also: pentaho.type.spec.UTypeModule |
UInstanceReference: |
---|
The Instance references are the main arguments of methods such as An instance reference can be an instance specification, used for constructing a new instance, or a resolve instance specification, used for resolving instances from the instances' container. Source: doc-js/pentaho/type/spec/UInstanceReference.jsdoc, line 17 |
UList: | Nully |
---|
A Like with all other value types, list values can be described using the general object form. The object form conforms to List values support an additional form of value specification, the array form: an array of Take the following example of a number list in object form:
In array form, if we assume the type of the list is implied, the same list could be written simply as:
However, note that array form can only be used if the A list of complex values can be written in array form, and its complex elements be written in array form, as well. For example:
When a list value is absent or empty, it can be described with a |
UModuleDependencyReference: | Object.<<code>string , pentaho.type.spec.UModuleDependencyReference > |
---|
The Dependency references are the main arguments of methods such as Examples
Source: doc-js/pentaho/type/spec/UModuleDependencyReference.jsdoc, line 17 See also: pentaho.type.spec.UInstanceModule , pentaho.type.spec.UTypeModule |
UPropertyTypeProto: |
---|
A When the value is a string, it's taken to represent a property whose Source: doc-js/pentaho/type/spec/UPropertyTypeProto.jsdoc, line 17 |
USimple: |
---|
A Like with all other value types, simple values can be described using the general object form. The object form conforms to The following is an example of an object form specification:
If the formatted is not defined, it can be written more concisely as:
or, simply, as:
Note that, when the underlying JavaScript value is a plain object, it must always be described using the generic object form,
When a simple value is absent, it can be described with a
Note, also, that a simple value cannot have a
A To know, exactly, which types of JavaScript values are accepted as specifications of a specific |
UTypeModule() |
---|
The A module is either the type factory function directly, or an array whose first elements are The type factory function can declare as many arguments as the dependency references that precede it in the module array. The function is called with the values of the The following is an example of the AMD module of a Type API type which is a subtype of Source: doc-js/pentaho/type/spec/UTypeModule.jsdoc, line 17 See also: pentaho.type.spec.UInstanceModule |
UTypeReference: | Array.<<code>pentaho.type.spec.UTypeReference > | pentaho.type.spec.ITypeProto |
---|
The It can be one of the following: A type id stringA type's permanent When an identifier is permanent and does not contain any "/" character, it is considered a standard type and is taken relative to Pentaho's Note that relative AMD module identifiers, such as "./foo", are not supported. Example absolute, permanent identifier:
Example temporary identifier:
An instance constructor functionA reference to an instance constructor, like Usually, a reference to an instance constructor is obtained from a Example:
A type objectA type's singleton object, like Example:
A generic type specification objectA plain The special Example:
A list type shorthand specification arrayA shorter specification syntax to reference the List type, or derived list types of varied Example: Source: doc-js/pentaho/type/spec/UTypeReference.jsdoc, line 17 |
UValue: |
---|
A When a value instance is described using object form, its specification is of type To describe an absent instance, use a |