Skip to main content
Hitachi Vantara Lumada and Pentaho Documentation

spec

pentaho.visual.role.spec

The visual.role.spec namespace contains specification classes for describing visual role mappings.

Source: doc-js/pentaho/visual/role/spec/_namespace.jsdoc, line 17

Interfaces

Name Summary
IMapping

The spec.IMapping interface describes the object form of a visual role mapping instance.

IMappingAttribute

The spec.IMappingAttribute interface describes the object form of a visual role mapping attribute instance.

Type Definitions

UMappingAttribute: pentaho.visual.role.spec.IMappingAttribute | string

A spec.UMappingAttribute represents the union of JS types that can be used to describe a visual role mapping attribute instance.

When an instance is described using object form, its specification is of the type spec.IMappingAttribute.

Alternatively, a single string can be used to describe an instance, in which case it is taken to be the value of the name property.

Source: doc-js/pentaho/visual/role/spec/UMappingAttribute.jsdoc, line 17